ObjFW  History of src/runtime/threading.m of 2b75f9e6a0cd6c67

History of the file that is called src/runtime/threading.m at check-in 2b75f9e6a0cd6c67

2024-01-02
17:17
Update copyright file: [0aef164090] check-in: [26ddd2e4e4] user: js, branch: trunk, size: 1205 [annotate] [blame] [check-ins using] [diff]
2023-01-06
09:04
Update copyright file: [05de45146b] check-in: [8939cbdb52] user: js, branch: trunk, size: 1205 [annotate] [blame] [check-ins using] [diff]
2022-02-12
07:46
Update copyright file: [f4000ae0f7] check-in: [1a86b8175b] user: js, branch: trunk, size: 1205 [annotate] [blame] [check-ins using] [diff]
2021-05-02
11:34
runtime: Name things more consistently file: [9fcf574ba3] check-in: [2b75f9e6a0] user: js, branch: trunk, size: 1205 [annotate] [blame] [check-ins using] [diff]
2021-04-18
20:51
Rename everything in several smaller files file: [34d13c2d7f] check-in: [35de667566] user: js, branch: new-naming-convention, size: 1207 [annotate] [blame] [check-ins using] [diff]
2021-04-17
16:24
of_mutex_t -> OFPlainMutex

Also rename of_rmutex_t -> OFPlainRecursiveMutex. file: [04a725fac0] check-in: [dfd52d5220] user: js, branch: new-naming-convention, size: 1197 [annotate] [blame] [check-ins using] [diff]

16:13
of_once_t -> OFOnceControl file: [50e87d61c7] check-in: [26aa88fc9b] user: js, branch: new-naming-convention, size: 1154 [annotate] [blame] [check-ins using] [diff]
2021-01-02
22:04
Update copyright file: [13c9aec71c] check-in: [374e1a1bfa] user: js, branch: trunk, size: 1143 [annotate] [blame] [check-ins using] [diff]
2020-12-20
21:26
Return error instead of using errno for threading

errno is problematic for Amiga libraries and is also not thread-safe on
some systems, even though it should. file: [4a1cc07735] check-in: [5b37fbeb82] user: js, branch: trunk, size: 1232 [annotate] [blame] [check-ins using] [diff]

2020-01-02
01:51
Update copyright file: [e792c643b3] check-in: [c7f0229795] user: js, branch: trunk, size: 1220 [annotate] [blame] [check-ins using] [diff]
2019-08-01
20:14
Split threading.[hm] into multiple files

This allows the runtime to only link against the parts it needs, without
pulling in unnecessary parts like thread spawning, TLS and conditions. file: [0ddddee005] check-in: [5358e9ea6a] user: js, branch: trunk, size: 1217 [annotate] [blame] [check-ins using] [diff]

2019-06-17
00:38
Remove underscores from library & framework names

This is more compatible with the various conventions used on various
systems. file: [4b5bfa32f7] check-in: [79fe29dbf4] user: js, branch: trunk, size: 1204 [annotate] [blame] [check-ins using] [diff]

2019-02-07
00:46
Make style consistent between ObjFW and ObjFW_RT

ObjFW_RT used to be a separate project that followed the BSD style, as
it was written in pure C, while ObjFW's style is based on the BSD style
with changes to make it a better fit for Objective-C. This commit
changes ObjFW_RT to use the same style as ObjFW. file: [7a03675ae5] check-in: [ef6d69931e] user: js, branch: trunk, size: 1205 [annotate] [blame] [check-ins using] [diff]

2019-01-03
19:13
Update copyright file: [5f55cac459] check-in: [0509d7a844] user: js, branch: trunk, size: 1209 [annotate] [blame] [check-ins using] [diff]
2018-03-18
01:01
socket.m: Minor cleanup

This should make the init behavior the same for --enable-threads and
--disable-threads. file: [f965e6303e] check-in: [885d84a1a7] user: js, branch: trunk, size: 1203 [annotate] [blame] [check-ins using] [diff]

2018-01-21
22:16
Allow building the runtime as a .framework

This also renames ObjFW-RT to ObjFW_RT, as hyphens should not be in
framework names. file: [485a93cc19] check-in: [0f42b0eafd] user: js, branch: trunk, size: 1202 [annotate] [blame] [check-ins using] [diff]

2018-01-03
19:49
Update copyright notice file: [94b640a762] check-in: [7e5c81e186] user: js, branch: trunk, size: 1202 [annotate] [blame] [check-ins using] [diff]
2017-07-09
15:29
runtime: Rename include to ObjFW-RT.h file: [13701244e7] check-in: [5bb771755d] user: js, branch: trunk, size: 1179 [annotate] [blame] [check-ins using] [diff]
2017-06-07
21:38
runtime: Move all globals into a single struct

This is required to create a .library on MorphOS. file: [e057f37307] check-in: [79011c5f56] user: js, branch: trunk, size: 1242 [annotate] [blame] [check-ins using] [diff]

2017-01-09
17:36
Update copyright

Forgot to add 2017, even though I already did quite some changes in
2017. file: [1fbcc9555d] check-in: [44f45c2e35] user: js, branch: trunk, size: 1186 [annotate] [blame] [check-ins using] [diff]

2016-01-03
00:41
Update copyright

While at it, also update the mail address. file: [94916166d1] check-in: [2a27cf3000] user: js, branch: trunk, size: 1180 [annotate] [blame] [check-ins using] [diff]

2015-08-09
15:01
Remove objc_global_mutex_free()

Since this is using of_once to initialize it, it won't be re-initialized
after freeing, therefore freeing is a bad idea. file: [c43c4c7c69] check-in: [2a73dbd64f] user: js, branch: trunk, size: 1176 [annotate] [blame] [check-ins using] [diff]

2015-01-03
20:57
Update copyright file: [7ebb50401c] check-in: [cfd374b906] user: js, branch: trunk, size: 1298 [annotate] [blame] [check-ins using] [diff]
2014-02-28
00:38
threading.h: Add of_once() file: [0bd9199ab6] check-in: [ba5e756264] user: js, branch: trunk, size: 1292 [annotate] [blame] [check-ins using] [diff]
2014-01-04
00:24
Update copyright. file: [ec09e7071d] check-in: [3b97fc3cd9] user: js, branch: trunk, size: 1351 [annotate] [blame] [check-ins using] [diff]
2013-03-04
17:20
Replace BOOL with bool.

The only places where BOOL is left are those where they are required by
the ABI. file: [8179cd42a3] check-in: [c5ef582958] user: js, branch: trunk, size: 1345 [annotate] [blame] [check-ins using] [diff]

2013-01-09
22:24
Update copyright. file: [1ff2ae8b0b] check-in: [813c00ccf0] user: js, branch: trunk, size: 1341 [annotate] [blame] [check-ins using] [diff]
2012-08-05
10:45
Add of_rmutex_t, a reentrant mutex implementation. file: [0fd3a6e663] check-in: [1cb3d9fef9] user: js, branch: trunk, size: 1335 [annotate] [blame] [check-ins using] [diff]
2012-07-17
01:09
Rename ERROR() to OBJC_ERROR().

ERROR seems to be defined on MinGW32 and it's likely that it's also used
on other systems, thus it's better to prefix it with OBJC_. file: [1343be0c29] check-in: [345eb93240] user: js, branch: trunk, size: 1926 [annotate] [blame] [check-ins using] [diff]

2012-04-22
16:05
Safer way to create the global mutex.

__attribute__((constructor)) might not have been called when the runtime
is first used. However, the first usage of the runtime is always
single-threaded, so it is safe to do it this way. file: [92014702e9] check-in: [51b73c821c] user: js, branch: runtime, size: 1906 [annotate] [blame] [check-ins using] [diff]

2012-04-21
10:56
Remove useless thread-checking. file: [2d30e1cc90] check-in: [555445ce0a] user: js, branch: runtime, size: 1819 [annotate] [blame] [check-ins using] [diff]
2012-03-06
17:19
Fix an evil typo. file: [7dca0646d4] check-in: [b3dd58a1ae] user: js, branch: runtime, size: 2809 [annotate] [blame] [check-ins using] [diff]
2012-03-04
20:20
Added: Import and integrate ObjFW-RT. file: [0fa31c9691] check-in: [129f90b580] user: js, branch: runtime, size: 2808 [annotate] [blame] [check-ins using]