ObjFW  History of src/resolver.h of 49cb6ada5f8e15f4

History of the file that is called src/resolver.h at check-in 49cb6ada5f8e15f4

2018-10-07
02:06
Deleted: Remove resolver.m

Instead, OFDNSResolver is used for everything now. (check-in: [6e9ee122eb] user: js, branch: trunk, size: 0)

2018-07-28
20:21
[8e4bcb1595] part of check-in [8aeee6680a] Add of_socket_address_ip_string()

This replaces of_address_to_string_and_port(). (check-in: [8aeee6680a] user: js, branch: trunk, size: 1764) [annotate] [blame] [check-ins using] [diff]

2018-01-03
19:49
[89d38aa172] part of check-in [7e5c81e186] Update copyright notice (check-in: [7e5c81e186] user: js, branch: trunk, size: 2423) [annotate] [blame] [check-ins using] [diff]
2017-05-07
20:10
[d006d1407a] part of check-in [4af49a13c3] Small code style change

Casts are now written like types in variable declarations. (check-in: [4af49a13c3] user: js, branch: trunk, size: 2400) [annotate] [blame] [check-ins using] [diff]

2017-02-04
17:45
[27e1b81eb2] part of check-in [5a31a537a1] Fix typos in comments and strings found by aspell (check-in: [5a31a537a1] user: js, branch: trunk, size: 2394) [annotate] [blame] [check-ins using] [diff]
2017-01-09
17:36
[7681ad00c7] part of check-in [44f45c2e35] Update copyright

Forgot to add 2017, even though I already did quite some changes in
2017. (check-in: [44f45c2e35] user: js, branch: trunk, size: 2395) [annotate] [blame] [check-ins using] [diff]

2016-01-03
00:43
[1a36d5c756] part of check-in [cec0f072f8] Update copyright

While at it, also update the mail address. (check-in: [cec0f072f8] user: js, branch: 0.8, size: 2403) [annotate] [blame] [check-ins using] [diff]

00:41
[61e89a3dd8] part of check-in [2a27cf3000] Update copyright

While at it, also update the mail address. (check-in: [2a27cf3000] user: js, branch: trunk, size: 2389) [annotate] [blame] [check-ins using] [diff]

2015-11-21
18:35
[5d077f79a9] part of check-in [d526d938d7] Remove OF_NULLABLE / OF_NONNULL

Now that Clang switched to use _Nullable and _Nonnull instead of
__nullable / __nonnull, there is no longer a conflict with glibc, which
means we can just define _Nullable / _Nonnull to nothing if they are not
understood by the compiler (which did not work with __nullable /
__nonnull due to this conflict).

This also defines _Null_unspecified to nothing if unavailable. (check-in: [d526d938d7] user: js, branch: trunk, size: 2385) [annotate] [blame] [check-ins using] [diff]

2015-06-14
10:45
[f92afcb5a7] part of check-in [b7097a67b6] Add OF_NONNULL / OF_NULLABLE and use that instead

Using __nonnull directly doesn't work on systems using glibc, as glibc
defines __nonnull as a parameterized define. While this does not fix the
problem of Clang introducing __nonnull even though it conflicts with
glibc, this at least means it's possible again to compile things with
versions of Clang that don't support __nonnull on systems with glibc. (check-in: [b7097a67b6] user: js, branch: trunk, size: 2399) [annotate] [blame] [check-ins using] [diff]

2015-06-13
22:26
[453d9528f7] part of check-in [9e76144ef8] Add support for and use the new nullability (check-in: [9e76144ef8] user: js, branch: trunk, size: 2392) [annotate] [blame] [check-ins using] [diff]
2015-01-03
20:57
[f71e91f385] part of check-in [cfd374b906] Update copyright (check-in: [cfd374b906] user: js, branch: trunk, size: 2257) [annotate] [blame] [check-ins using] [diff]
2014-02-18
18:50
[aea9af8509] part of check-in [246cfe0807] Documentation: Show correct imports (check-in: [246cfe0807] user: js, branch: trunk, size: 2251) [annotate] [blame] [check-ins using] [diff]
2014-01-30
12:26
[2d84450251] part of check-in [fb590316ba] Rename +[UDPSocket hostForAddress:port:]

It is now called +[getHost:andPort:forAddress:]. This makes it much
clearer from the selector alone what it actually does. (check-in: [fb590316ba] user: js, branch: trunk, size: 2209) [annotate] [blame] [check-ins using] [diff]

2014-01-29
09:54
[2514a83524] part of check-in [dfd8e14567] resolver.h: Rename private to private_ for C++ (check-in: [dfd8e14567] user: js, branch: trunk, size: 2084) [annotate] [blame] [check-ins using] [diff]
2014-01-27
12:34
[a012300f05] part of check-in [44c595058b] of_address_to_string: Add a way to get the port (check-in: [44c595058b] user: js, branch: trunk, size: 2083) [annotate] [blame] [check-ins using] [diff]
2014-01-26
22:38
Added: [5eef0c526a] part of check-in [49b1989b63] Move resolving functionality to resolver.m

This is in preparation for UDP sockets, so that they can share the
resolving functionality with TCP sockets. (check-in: [49b1989b63] user: js, branch: trunk, size: 1913) [annotate] [blame] [check-ins using]