ObjFW  All files named "src/OFString+Hashing.m"

History for src/OFString+Hashing.m

2016-07-24
00:06
Deleted: Rename OFHash to OFCryptoHash

OFHash is too generic, as this protocol is for cryptographic hashes. It
also solves the ambiguity of the +[hash] method (which is now
+[cryptoHash]), which conflicted with -[hash] on the class itself,
resulting in classes conforming to OFHash not being able to be used as a
key in an OFDictionary. check-in: [951f530aee] user: js, branch: trunk, size: 0

2016-02-21
15:37
Make use of C99-style for loops file: [0bdccbd7c3] check-in: [e0b9167693] user: js, branch: trunk, size: 2271 [annotate] [blame] [check-ins using] [diff]
2016-01-03
00:41
Update copyright

While at it, also update the mail address. file: [8511d233d9] check-in: [2a27cf3000] user: js, branch: trunk, size: 2275 [annotate] [blame] [check-ins using] [diff]

2015-01-03
20:57
Update copyright file: [4b102cb9d0] check-in: [cfd374b906] user: js, branch: trunk, size: 2271 [annotate] [blame] [check-ins using] [diff]
2014-09-03
22:22
Add OFRIPEMD160Hash file: [7a445a45c7] check-in: [126d9d3aa1] user: js, branch: trunk, size: 2265 [annotate] [blame] [check-ins using] [diff]
15:46
Add OFSHA384Hash and OFSHA512Hash file: [f876fe99fb] check-in: [23f6c0f84d] user: js, branch: trunk, size: 2140 [annotate] [blame] [check-ins using] [diff]
2014-09-01
23:42
Add OFSHA224Hash

This creates a common base for OFSHA224Hash and OFSHA256Hash so that all
code (except the different initialization constants) is reused. file: [7422385e15] check-in: [a1931f59a2] user: js, branch: trunk, size: 1908 [annotate] [blame] [check-ins using] [diff]

11:08
Add OFSHA256Hash

Took me some time to figure out the RFC is buggy and SSIG0(t-15) should
be SSIG0(W(t-15))... file: [ef503698d2] check-in: [46af1252a5] user: js, branch: trunk, size: 1792 [annotate] [blame] [check-ins using] [diff]

2014-06-21
21:43
Move all macros from OFObject.h to macros.h

This means that OFObject.h imports macros.h now, making it unnecessary
to manually import macros.h in almost every file. And while at it, also
import autorelease.h in OFObject.h, so that this doesn't need to be
manually imported in almost every file as well. file: [ec17a0338c] check-in: [13ee56edf3] user: js, branch: trunk, size: 1676 [annotate] [blame] [check-ins using] [diff]

2014-01-04
00:24
Update copyright. file: [18dda25665] check-in: [3b97fc3cd9] user: js, branch: trunk, size: 1701 [annotate] [blame] [check-ins using] [diff]
2013-12-08
17:43
Clean up OFHash and the Hashing categories. file: [903e063a45] check-in: [75f2aa5096] user: js, branch: trunk, size: 1695 [annotate] [blame] [check-ins using] [diff]
2013-01-09
22:24
Update copyright. file: [19f8d7a88b] check-in: [813c00ccf0] user: js, branch: trunk, size: 2054 [annotate] [blame] [check-ins using] [diff]
2012-10-09
15:07
Make use of instancetype. file: [e9a2adf039] check-in: [fb515e8e24] user: js, branch: trunk, size: 2048 [annotate] [blame] [check-ins using] [diff]
2012-08-10
20:08
Directly use the runtime's autorelease pools.

This greatly improves performance, as it gets rid of the overhead of
OFAutoreleasePool. file: [c7fc790b94] check-in: [1255f3a11a] user: js, branch: trunk, size: 2047 [annotate] [blame] [check-ins using] [diff]

2012-07-03
20:16
OFHash: Take void* and unify convenience methods. file: [e987d561c5] check-in: [c1060114f6] user: js, branch: trunk, size: 2060 [annotate] [blame] [check-ins using] [diff]
2012-01-05
00:56
Update copyright. file: [07ba26d618] check-in: [ce70e17b38] user: js, branch: trunk, size: 2067 [annotate] [blame] [check-ins using] [diff]
2011-09-12
19:57
Rename -[cString] to -[UTF8String]. file: [80d2670e52] check-in: [e6fd39d11e] user: js, branch: trunk, size: 2061 [annotate] [blame] [check-ins using] [diff]
2011-07-08
15:29
Make it possible to add more ivars to OFConstantString. file: [9a2cc09f1a] check-in: [0b846bcc4a] user: js, branch: trunk, size: 1967 [annotate] [blame] [check-ins using] [diff]
2011-04-23
13:23
More style improvements. file: [afd3c22e1b] check-in: [6f4bf74c7d] user: js, branch: trunk, size: 1923 [annotate] [blame] [check-ins using] [diff]
2011-04-22
20:19
More style improvements. file: [4e1492dfab] check-in: [e76a7f52c1] user: js, branch: trunk, size: 1955 [annotate] [blame] [check-ins using] [diff]
2011-02-04
16:01
Add OFDataArray (Hashing) category. file: [856205c228] check-in: [38057e75f0] user: js, branch: trunk, size: 1939 [annotate] [blame] [check-ins using] [diff]
2011-01-01
20:19
Change license. file: [780c4c8311] check-in: [da6b3d26cb] user: js, branch: trunk, size: 1886 [annotate] [blame] [check-ins using] [diff]
2010-10-24
13:30
Always write abbreviations uppercase in method names. file: [43e21d118e] check-in: [1d19a5586b] user: js, branch: trunk, size: 1630 [annotate] [blame] [check-ins using] [diff]
2010-06-12
20:47
Added: Move a few classes and categories so they have their own files. file: [55b99ed0be] check-in: [67917b918a] user: js, branch: trunk, size: 1630 [annotate] [blame] [check-ins using]