ObjFW  All files named "src/OFString+CryptoHashing.m"

History for src/OFString+CryptoHashing.m

2022-07-15
18:09
Renamed to src/OFString+CryptographicHashing.m. Merge trunk into branch "wii-u" check-in: [a2973418de] user: js, branch: wii-u, size: 0
2021-05-09
14:45
Renamed to src/OFString+CryptographicHashing.m. Merge trunk into branch "amiga-library"

All necessary changes to adjust for the changes made in trunk are
included in the merge commit. check-in: [3c88df0ce4] user: js, branch: amiga-library, size: 0

2021-04-07
21:18
Renamed to src/OFString+CryptographicHashing.m. Merge trunk into 1.0 branch check-in: [36669d22b4] user: js, branch: 1.0, size: 0
21:14
Renamed to src/OFString+CryptographicHashing.m. Rename OFCryptoHash -> OFCryptographicHash check-in: [2969086342] user: js, branch: trunk, size: 0
19:22
OF{Data,String}+CryptoHashing: Rename methods

This makes it clearer that these return a string and not a hash object. file: [e8341b8291] check-in: [b5a74319e1] user: js, branch: trunk, size: 2354 [annotate] [blame] [check-ins using] [diff]

2021-03-07
20:25
*.m: Fold methods into one line where it fits file: [826ee219c6] check-in: [1b82d3bf4f] user: js, branch: trunk, size: 2277 [annotate] [blame] [check-ins using] [diff]
2021-01-02
22:04
Update copyright file: [0a23b41efc] check-in: [374e1a1bfa] user: js, branch: trunk, size: 2280 [annotate] [blame] [check-ins using] [diff]
2020-01-02
01:51
Update copyright file: [9d43bb7986] check-in: [c7f0229795] user: js, branch: trunk, size: 2369 [annotate] [blame] [check-ins using] [diff]
2019-12-27
00:41
OFSecureData: Add allowsSwappableMemory property

With this property, it's possible to specify whether the memory should
be protected from swapping or not. This makes it easier for e.g. the
crypto hash classes: They can now just always use OFSecureData without
wasting unswappable memory if it's not needed. file: [2bc09b0ad0] check-in: [e629dc83a9] user: js, branch: trunk, size: 2366 [annotate] [blame] [check-ins using] [diff]

2019-03-08
00:35
Use dot syntax file: [d7c7a2d4d1] check-in: [bceb7ed4c9] user: js, branch: trunk, size: 2330 [annotate] [blame] [check-ins using] [diff]
2019-01-03
19:13
Update copyright file: [cd0a1a49d0] check-in: [0509d7a844] user: js, branch: trunk, size: 2336 [annotate] [blame] [check-ins using] [diff]
2018-01-03
19:49
Update copyright notice file: [66f8955039] check-in: [7e5c81e186] user: js, branch: trunk, size: 2330 [annotate] [blame] [check-ins using] [diff]
2017-05-21
21:28
Prefix private methods with of_ instead of OF_

This matches Apple's style. file: [68de61fc18] check-in: [6b77a5dd8b] user: js, branch: trunk, size: 2307 [annotate] [blame] [check-ins using] [diff]

2017-05-07
20:10
Small code style change

Casts are now written like types in variable declarations. file: [78fa704049] check-in: [4af49a13c3] user: js, branch: trunk, size: 2307 [annotate] [blame] [check-ins using] [diff]

2017-01-09
17:36
Update copyright

Forgot to add 2017, even though I already did quite some changes in
2017. file: [2a2048b5b4] check-in: [44f45c2e35] user: js, branch: trunk, size: 2299 [annotate] [blame] [check-ins using] [diff]

2016-07-24
12:14
-[OFCryptoHash digest]: uint8_t -> unsigned char

While in practice they are usually the same, the C standard says that
only char does not have any alignment requirements. As (u)int*_t is
defined to be an integer type of the specified size, it does not mean
(u)int8_t needs to be char. file: [fc8a2533b9] check-in: [19f7dc67af] user: js, branch: trunk, size: 2293 [annotate] [blame] [check-ins using] [diff]

00:06
Added: Rename OFHash to OFCryptoHash

OFHash is too generic, as this protocol is for cryptographic hashes. It
also solves the ambiguity of the +[hash] method (which is now
+[cryptoHash]), which conflicted with -[hash] on the class itself,
resulting in classes conforming to OFHash not being able to be used as a
key in an OFDictionary. file: [73f20bd87d] check-in: [951f530aee] user: js, branch: trunk, size: 2287 [annotate] [blame] [check-ins using]