ObjFW  All files named "src/OFString+CryptoHashing.h"

History for src/OFString+CryptoHashing.h

2022-07-15
18:09
Renamed to src/OFString+CryptographicHashing.h. Merge trunk into branch "wii-u" check-in: [a2973418de] user: js, branch: wii-u, size: 0
2021-04-07
21:18
Renamed to src/OFString+CryptographicHashing.h. Merge trunk into 1.0 branch check-in: [36669d22b4] user: js, branch: 1.0, size: 0
21:14
Renamed to src/OFString+CryptographicHashing.h. Rename OFCryptoHash -> OFCryptographicHash check-in: [2969086342] user: js, branch: trunk, size: 0
19:22
OF{Data,String}+CryptoHashing: Rename methods

This makes it clearer that these return a string and not a hash object. file: [a8ec191fe6] check-in: [b5a74319e1] user: js, branch: trunk, size: 1639 [annotate] [blame] [check-ins using] [diff]

2021-01-02
22:04
Update copyright file: [562278ea0b] check-in: [374e1a1bfa] user: js, branch: trunk, size: 1562 [annotate] [blame] [check-ins using] [diff]
2020-10-03
11:35
Use /** */ instead of /*! */ for documentation file: [6628c49341] check-in: [163a4a5a2e] user: js, branch: trunk, size: 1651 [annotate] [blame] [check-ins using] [diff]
2020-01-02
01:51
Update copyright file: [5831ee8a85] check-in: [c7f0229795] user: js, branch: trunk, size: 1651 [annotate] [blame] [check-ins using] [diff]
2019-01-03
19:13
Update copyright file: [88cd5bed9c] check-in: [0509d7a844] user: js, branch: trunk, size: 1648 [annotate] [blame] [check-ins using] [diff]
2018-01-03
19:49
Update copyright notice file: [c6a2f6d7ff] check-in: [7e5c81e186] user: js, branch: trunk, size: 1642 [annotate] [blame] [check-ins using] [diff]
2017-11-18
18:50
Documentation: Use @brief for all properties file: [01ed53c71f] check-in: [cc3ad3ddd3] user: js, branch: trunk, size: 1619 [annotate] [blame] [check-ins using] [diff]
2017-10-29
21:58
Convert methods to properties where appropriate

This improves Swift compatibility. file: [60e0201519] check-in: [f3ccf14461] user: js, branch: trunk, size: 1570 [annotate] [blame] [check-ins using] [diff]

2017-05-07
20:10
Small code style change

Casts are now written like types in variable declarations. file: [f63a3a4a9b] check-in: [4af49a13c3] user: js, branch: trunk, size: 2099 [annotate] [blame] [check-ins using] [diff]

2017-01-09
17:36
Update copyright

Forgot to add 2017, even though I already did quite some changes in
2017. file: [3e61516736] check-in: [44f45c2e35] user: js, branch: trunk, size: 2092 [annotate] [blame] [check-ins using] [diff]

2016-07-24
00:06
Added: Rename OFHash to OFCryptoHash

OFHash is too generic, as this protocol is for cryptographic hashes. It
also solves the ambiguity of the +[hash] method (which is now
+[cryptoHash]), which conflicted with -[hash] on the class itself,
resulting in classes conforming to OFHash not being able to be used as a
key in an OFDictionary. file: [bdbd026aa6] check-in: [951f530aee] user: js, branch: trunk, size: 2086 [annotate] [blame] [check-ins using]