ObjFW  History of src/OFSHA384Or512Hash.m of e629dc83a9aea147

History of the file that is called src/OFSHA384Or512Hash.m at check-in e629dc83a9aea147

2024-04-03
02:16
[3134f6cb6f] part of check-in [7413a728a7] Change license to LGPLv3 only (check-in: [7413a728a7] user: js, branch: trunk, size: 7599) [annotate] [blame] [check-ins using] [diff]
2024-01-02
17:17
[600cda42b7] part of check-in [26ddd2e4e4] Update copyright (check-in: [26ddd2e4e4] user: js, branch: trunk, size: 7391) [annotate] [blame] [check-ins using] [diff]
2023-01-06
09:04
[6fba86c137] part of check-in [8939cbdb52] Update copyright (check-in: [8939cbdb52] user: js, branch: trunk, size: 7391) [annotate] [blame] [check-ins using] [diff]
2022-03-25
10:22
[f0d2e79fad] part of check-in [82801897d3] OFCryptographicHash: Add -[calculate]

Before, -[digest] would do the final calculation, however, this would
mean a property modifies state, which is bad. (check-in: [82801897d3] user: js, branch: trunk, size: 7391) [annotate] [blame] [check-ins using] [diff]

2022-02-12
07:46
[1c897d691a] part of check-in [1a86b8175b] Update copyright (check-in: [1a86b8175b] user: js, branch: trunk, size: 7211) [annotate] [blame] [check-ins using] [diff]
2021-04-25
11:05
[e382c5ef41] part of check-in [27103855c2] A few last renames (check-in: [27103855c2] user: js, branch: new-naming-convention, size: 7211) [annotate] [blame] [check-ins using] [diff]
2021-04-18
15:55
[ec2747a474] part of check-in [7392685ffc] Rename all functions in macros.h (check-in: [7392685ffc] user: js, branch: new-naming-convention, size: 7199) [annotate] [blame] [check-ins using] [diff]
2021-04-07
21:14
[4e88edca81] part of check-in [2969086342] Rename OFCryptoHash -> OFCryptographicHash (check-in: [2969086342] user: js, branch: trunk, size: 7174) [annotate] [blame] [check-ins using] [diff]
2021-03-07
20:25
[d2d324bc83] part of check-in [1b82d3bf4f] *.m: Fold methods into one line where it fits (check-in: [1b82d3bf4f] user: js, branch: trunk, size: 7180) [annotate] [blame] [check-ins using] [diff]
2021-01-02
22:04
[e89cdc8f14] part of check-in [374e1a1bfa] Update copyright (check-in: [374e1a1bfa] user: js, branch: trunk, size: 7184) [annotate] [blame] [check-ins using] [diff]
2020-06-28
15:03
[d2c6b72c05] part of check-in [b6cb3addd0] Use OF_DIRECT(_MEMBERS) where appropriate (check-in: [b6cb3addd0] user: js, branch: trunk, size: 7291) [annotate] [blame] [check-ins using] [diff]
2020-01-02
01:51
[2e85a85b06] part of check-in [c7f0229795] Update copyright (check-in: [c7f0229795] user: js, branch: trunk, size: 7273) [annotate] [blame] [check-ins using] [diff]
2019-12-27
00:41
[aa0c17c5cb] part of check-in [e629dc83a9] OFSecureData: Add allowsSwappableMemory property

With this property, it's possible to specify whether the memory should
be protected from swapping or not. This makes it easier for e.g. the
crypto hash classes: They can now just always use OFSecureData without
wasting unswappable memory if it's not needed. (check-in: [e629dc83a9] user: js, branch: trunk, size: 7270) [annotate] [blame] [check-ins using] [diff]

2019-03-12
22:10
[b218fc3078] part of check-in [320d638a21] OFCryptoHash: Add property for digest / block size (check-in: [320d638a21] user: js, branch: trunk, size: 6841) [annotate] [blame] [check-ins using] [diff]
2019-03-08
00:35
[af9afb2e15] part of check-in [bceb7ed4c9] Use dot syntax (check-in: [bceb7ed4c9] user: js, branch: trunk, size: 6713) [annotate] [blame] [check-ins using] [diff]
2019-01-03
19:13
[9b71b4cd6a] part of check-in [0509d7a844] Update copyright (check-in: [0509d7a844] user: js, branch: trunk, size: 6705) [annotate] [blame] [check-ins using] [diff]
2018-04-07
20:05
[9bae79c3a2] part of check-in [a5006f1d31] OF*Hash: Make use of the new OFSecureData (check-in: [a5006f1d31] user: js, branch: trunk, size: 6699) [annotate] [blame] [check-ins using] [diff]
2018-01-03
19:49
[12196f165c] part of check-in [7e5c81e186] Update copyright notice (check-in: [7e5c81e186] user: js, branch: trunk, size: 6141) [annotate] [blame] [check-ins using] [diff]
2017-10-17
00:33
[7ebbc5c21e] part of check-in [2f4e0df8be] Do not use implicit method return types

Instead, explicitly declare them, as OF_ASSUME_NONNULL_{BEGIN,END} does
not apply to implicit return types. This means that after this commit,
all init methods have a nonnull return type, as they should have. (check-in: [2f4e0df8be] user: js, branch: trunk, size: 6118) [annotate] [blame] [check-ins using] [diff]

2017-05-21
21:28
[6ff07dab9e] part of check-in [6b77a5dd8b] Prefix private methods with of_ instead of OF_

This matches Apple's style. (check-in: [6b77a5dd8b] user: js, branch: trunk, size: 6100) [annotate] [blame] [check-ins using] [diff]

2017-05-07
20:10
[d5b60b898c] part of check-in [4af49a13c3] Small code style change

Casts are now written like types in variable declarations. (check-in: [4af49a13c3] user: js, branch: trunk, size: 6039) [annotate] [blame] [check-ins using] [diff]

2017-01-09
17:36
[51d3c14901] part of check-in [44f45c2e35] Update copyright

Forgot to add 2017, even though I already did quite some changes in
2017. (check-in: [44f45c2e35] user: js, branch: trunk, size: 6035) [annotate] [blame] [check-ins using] [diff]

2016-07-24
20:05
[3824d79a3c] part of check-in [096dd743b5] OF*Hash: Call [self reset] in -[dealloc] (check-in: [096dd743b5] user: js, branch: trunk, size: 6029) [annotate] [blame] [check-ins using] [diff]
18:54
[775711ae59] part of check-in [b1cd76a8cd] OFCryptoHash: Conform to OFCopying (check-in: [b1cd76a8cd] user: js, branch: trunk, size: 5975) [annotate] [blame] [check-ins using] [diff]
12:14
[5c6c4dfe45] part of check-in [19f7dc67af] -[OFCryptoHash digest]: uint8_t -> unsigned char

While in practice they are usually the same, the C standard says that
only char does not have any alignment requirements. As (u)int*_t is
defined to be an integer type of the specified size, it does not mean
(u)int8_t needs to be char. (check-in: [19f7dc67af] user: js, branch: trunk, size: 5676) [annotate] [blame] [check-ins using] [diff]

00:06
[43577ec262] part of check-in [951f530aee] Rename OFHash to OFCryptoHash

OFHash is too generic, as this protocol is for cryptographic hashes. It
also solves the ambiguity of the +[hash] method (which is now
+[cryptoHash]), which conflicted with -[hash] on the class itself,
resulting in classes conforming to OFHash not being able to be used as a
key in an OFDictionary. (check-in: [951f530aee] user: js, branch: trunk, size: 5670) [annotate] [blame] [check-ins using] [diff]

2016-02-21
15:37
[e332bfebbc] part of check-in [e0b9167693] Make use of C99-style for loops (check-in: [e0b9167693] user: js, branch: trunk, size: 5471) [annotate] [blame] [check-ins using] [diff]
2016-01-05
22:00
[0930b3cee0] part of check-in [d3158d091f] (u)int_fast*_t -> (u)int*_t

(U)INT_FAST*_MAX is broken on Android, which makes (u)int_fast*_t
dangerous to use while it does not provide any real speed benefit. (check-in: [d3158d091f] user: js, branch: trunk, size: 5476) [annotate] [blame] [check-ins using] [diff]

2016-01-03
00:43
[4265f0992f] part of check-in [cec0f072f8] Update copyright

While at it, also update the mail address. (check-in: [cec0f072f8] user: js, branch: 0.8, size: 5662) [annotate] [blame] [check-ins using] [diff]

00:41
[ba305d5941] part of check-in [2a27cf3000] Update copyright

While at it, also update the mail address. (check-in: [2a27cf3000] user: js, branch: trunk, size: 5491) [annotate] [blame] [check-ins using] [diff]

2015-11-29
11:43
[4224bef66b] part of check-in [48980f2297] Make properties a requirement and clean up code

This increases the required GCC version from 4.0 to 4.6 (exception:
Apple GCC, which already supports this with >= 4.0 starting with OS X
10.5). Since even GCC 4.6 is really old by now, there is no point in
still supporting something even older and making the code ugly because
of that. While some hardware and OS support was dropped from GCC 4.6
compared to GCC 4.0, there is nothing in there that would be an
interesting target with the exception of BeOS maybe - but a port to BeOS
can also be achieved using the Haiku support. The other dropped OSes are
mostly old versions of OSes while newer ones are still being supported
(and those newer versions of those OSes still support the same
hardware). (check-in: [48980f2297] user: js, branch: trunk, size: 5487) [annotate] [blame] [check-ins using] [diff]

2015-11-02
19:27
[aff18d378f] part of check-in [6a3c47863d] OFSHA*Hash: Minor cleanup (check-in: [6a3c47863d] user: js, branch: trunk, size: 5495) [annotate] [blame] [check-ins using] [diff]
2015-02-01
00:47
[139ebf49f1] part of check-in [7c27db9fe0] Add -[OFHash reset]

This is useful to calculate many hashes without allocating new objects. (check-in: [7c27db9fe0] user: js, branch: trunk, size: 5658) [annotate] [blame] [check-ins using] [diff]

2015-01-31
11:46
[4636315b6a] part of check-in [c56b388459] OF{MD5,RIPEMD160,SHA*}Hash: Small optimization (check-in: [c56b388459] user: js, branch: trunk, size: 5447) [annotate] [blame] [check-ins using] [diff]
2015-01-03
20:57
[719d2776ca] part of check-in [cfd374b906] Update copyright (check-in: [cfd374b906] user: js, branch: trunk, size: 5414) [annotate] [blame] [check-ins using] [diff]
2014-09-03
15:46
Added: [34c2d04713] part of check-in [23f6c0f84d] Add OFSHA384Hash and OFSHA512Hash (check-in: [23f6c0f84d] user: js, branch: trunk, size: 5408) [annotate] [blame] [check-ins using]