ObjFW  History of src/OFSHA384Or512Hash.h of e0459c419cca642f

History of the file that is called src/OFSHA384Or512Hash.h at checkin e0459c419cca642f

2021-04-07
21:14
Rename OFCryptoHash -> OFCryptographicHash file: [a9ade386ad] check-in: [2969086342] user: js, branch: trunk, size: 1192 [annotate] [blame] [check-ins using] [diff]
2021-01-02
22:04
Update copyright file: [f783b37416] check-in: [374e1a1bfa] user: js, branch: trunk, size: 1178 [annotate] [blame] [check-ins using] [diff]
2020-10-03
11:35
Use /** */ instead of /*! */ for documentation file: [2b8816dd44] check-in: [163a4a5a2e] user: js, branch: trunk, size: 1267 [annotate] [blame] [check-ins using] [diff]
2020-09-26
21:58
Don't require __COUNTER__ for OF_RESERVE_IVARS

__COUNTER__ does not exist in GCC 4.2, and Apple GCC 4.2 is still the
newest compiler available for macOS 10.5. file: [24a731b598] check-in: [ef614a225d] user: js, branch: trunk, size: 1267 [annotate] [blame] [check-ins using] [diff]

2020-04-19
14:52
Reduce usage of unions file: [e5381155b9] check-in: [e0459c419c] user: js, branch: trunk, size: 1248 [annotate] [blame] [check-ins using] [diff]
2020-01-02
01:51
Update copyright file: [b0f0d3732f] check-in: [c7f0229795] user: js, branch: trunk, size: 1242 [annotate] [blame] [check-ins using] [diff]
2019-12-27
00:41
OFSecureData: Add allowsSwappableMemory property

With this property, it's possible to specify whether the memory should
be protected from swapping or not. This makes it easier for e.g. the
crypto hash classes: They can now just always use OFSecureData without
wasting unswappable memory if it's not needed. file: [e24eeb0338] check-in: [e629dc83a9] user: js, branch: trunk, size: 1239 [annotate] [blame] [check-ins using] [diff]

2019-09-29
20:53
Reduce ivar scopes file: [10ea7023d1] check-in: [e0a330b377] user: js, branch: trunk, size: 1209 [annotate] [blame] [check-ins using] [diff]
19:35
Either restrict subclassing or reserve ivar space

This allows ABI stability with the fragile ABI. file: [835b1d3d02] check-in: [496695d778] user: js, branch: trunk, size: 1180 [annotate] [blame] [check-ins using] [diff]

2019-01-03
19:13
Update copyright file: [da5458033a] check-in: [0509d7a844] user: js, branch: trunk, size: 1159 [annotate] [blame] [check-ins using] [diff]
2018-04-07
20:05
OF*Hash: Make use of the new OFSecureData file: [9c753764f8] check-in: [a5006f1d31] user: js, branch: trunk, size: 1153 [annotate] [blame] [check-ins using] [diff]
2018-01-03
19:49
Update copyright notice file: [b64a6668e5] check-in: [7e5c81e186] user: js, branch: trunk, size: 1052 [annotate] [blame] [check-ins using] [diff]
2017-05-21
21:28
Prefix private methods with of_ instead of OF_

This matches Apple's style. file: [557203084b] check-in: [6b77a5dd8b] user: js, branch: trunk, size: 1029 [annotate] [blame] [check-ins using] [diff]

2017-04-02
16:02
Avoid the anonymous namespace for ObjC++ with GCC file: [cfc249c62f] check-in: [35934a9594] user: js, branch: trunk, size: 1053 [annotate] [blame] [check-ins using] [diff]
2017-01-09
17:36
Update copyright

Forgot to add 2017, even though I already did quite some changes in
2017. file: [a479ed6cf0] check-in: [44f45c2e35] user: js, branch: trunk, size: 1023 [annotate] [blame] [check-ins using] [diff]

2016-07-24
00:06
Rename OFHash to OFCryptoHash

OFHash is too generic, as this protocol is for cryptographic hashes. It
also solves the ambiguity of the +[hash] method (which is now
+[cryptoHash]), which conflicted with -[hash] on the class itself,
resulting in classes conforming to OFHash not being able to be used as a
key in an OFDictionary. file: [7857c565bc] check-in: [951f530aee] user: js, branch: trunk, size: 1017 [annotate] [blame] [check-ins using] [diff]

2016-01-03
00:41
Update copyright

While at it, also update the mail address. file: [f3c6e027c1] check-in: [2a27cf3000] user: js, branch: trunk, size: 1005 [annotate] [blame] [check-ins using] [diff]

2015-06-13
22:26
Add support for and use the new nullability file: [5aec9e9b8a] check-in: [9e76144ef8] user: js, branch: trunk, size: 1001 [annotate] [blame] [check-ins using] [diff]
2015-02-01
00:47
Add -[OFHash reset]

This is useful to calculate many hashes without allocating new objects. file: [468a3cb6e2] check-in: [7c27db9fe0] user: js, branch: trunk, size: 953 [annotate] [blame] [check-ins using] [diff]

2015-01-03
20:57
Update copyright file: [d13d87a9f5] check-in: [cfd374b906] user: js, branch: trunk, size: 929 [annotate] [blame] [check-ins using] [diff]
2014-09-03
15:46
Added: Add OFSHA384Hash and OFSHA512Hash file: [8ae53ec361] check-in: [23f6c0f84d] user: js, branch: trunk, size: 923 [annotate] [blame] [check-ins using]