ObjFW  History of src/OFSHA224Or256Hash.m of 1b82d3bf4f13fac7

History of the file that is called src/OFSHA224Or256Hash.m at check-in 1b82d3bf4f13fac7

2024-01-02
17:17
Update copyright file: [1df2737893] check-in: [26ddd2e4e4] user: js, branch: trunk, size: 6483 [annotate] [blame] [check-ins using] [diff]
2023-01-06
09:04
Update copyright file: [4f217678ce] check-in: [8939cbdb52] user: js, branch: trunk, size: 6483 [annotate] [blame] [check-ins using] [diff]
2022-03-25
10:22
OFCryptographicHash: Add -[calculate]

Before, -[digest] would do the final calculation, however, this would
mean a property modifies state, which is bad. file: [de7aa6c8f4] check-in: [82801897d3] user: js, branch: trunk, size: 6483 [annotate] [blame] [check-ins using] [diff]

2022-02-12
07:46
Update copyright file: [19bc34b26d] check-in: [1a86b8175b] user: js, branch: trunk, size: 6303 [annotate] [blame] [check-ins using] [diff]
2021-04-25
11:05
A few last renames file: [e18ccf9292] check-in: [27103855c2] user: js, branch: new-naming-convention, size: 6303 [annotate] [blame] [check-ins using] [diff]
2021-04-18
15:55
Rename all functions in macros.h file: [3300a90d56] check-in: [7392685ffc] user: js, branch: new-naming-convention, size: 6291 [annotate] [blame] [check-ins using] [diff]
2021-04-07
21:14
Rename OFCryptoHash -> OFCryptographicHash file: [1d1ad26ec5] check-in: [2969086342] user: js, branch: trunk, size: 6257 [annotate] [blame] [check-ins using] [diff]
2021-03-07
20:25
*.m: Fold methods into one line where it fits file: [e77f5555d4] check-in: [1b82d3bf4f] user: js, branch: trunk, size: 6263 [annotate] [blame] [check-ins using] [diff]
2021-01-02
22:04
Update copyright file: [06995323d9] check-in: [374e1a1bfa] user: js, branch: trunk, size: 6267 [annotate] [blame] [check-ins using] [diff]
2020-06-28
15:03
Use OF_DIRECT(_MEMBERS) where appropriate file: [86f8d9edad] check-in: [b6cb3addd0] user: js, branch: trunk, size: 6374 [annotate] [blame] [check-ins using] [diff]
2020-01-02
01:51
Update copyright file: [4e2317a38c] check-in: [c7f0229795] user: js, branch: trunk, size: 6356 [annotate] [blame] [check-ins using] [diff]
2019-12-27
00:41
OFSecureData: Add allowsSwappableMemory property

With this property, it's possible to specify whether the memory should
be protected from swapping or not. This makes it easier for e.g. the
crypto hash classes: They can now just always use OFSecureData without
wasting unswappable memory if it's not needed. file: [dbb6d31956] check-in: [e629dc83a9] user: js, branch: trunk, size: 6353 [annotate] [blame] [check-ins using] [diff]

2019-03-12
22:10
OFCryptoHash: Add property for digest / block size file: [01743762af] check-in: [320d638a21] user: js, branch: trunk, size: 5924 [annotate] [blame] [check-ins using] [diff]
2019-03-08
00:35
Use dot syntax file: [01186e5528] check-in: [bceb7ed4c9] user: js, branch: trunk, size: 5796 [annotate] [blame] [check-ins using] [diff]
2019-01-03
19:13
Update copyright file: [86260419b7] check-in: [0509d7a844] user: js, branch: trunk, size: 5788 [annotate] [blame] [check-ins using] [diff]
2018-04-07
20:05
OF*Hash: Make use of the new OFSecureData file: [31a535c436] check-in: [a5006f1d31] user: js, branch: trunk, size: 5782 [annotate] [blame] [check-ins using] [diff]
2018-01-03
19:49
Update copyright notice file: [2d148c64a2] check-in: [7e5c81e186] user: js, branch: trunk, size: 5225 [annotate] [blame] [check-ins using] [diff]
2017-10-17
00:33
Do not use implicit method return types

Instead, explicitly declare them, as OF_ASSUME_NONNULL_{BEGIN,END} does
not apply to implicit return types. This means that after this commit,
all init methods have a nonnull return type, as they should have. file: [223f1ca854] check-in: [2f4e0df8be] user: js, branch: trunk, size: 5202 [annotate] [blame] [check-ins using] [diff]

2017-05-21
21:28
Prefix private methods with of_ instead of OF_

This matches Apple's style. file: [280841ab34] check-in: [6b77a5dd8b] user: js, branch: trunk, size: 5184 [annotate] [blame] [check-ins using] [diff]

2017-05-07
20:10
Small code style change

Casts are now written like types in variable declarations. file: [07e1179a49] check-in: [4af49a13c3] user: js, branch: trunk, size: 5123 [annotate] [blame] [check-ins using] [diff]

2017-01-09
17:36
Update copyright

Forgot to add 2017, even though I already did quite some changes in
2017. file: [fb3b52794b] check-in: [44f45c2e35] user: js, branch: trunk, size: 5119 [annotate] [blame] [check-ins using] [diff]

2016-07-24
20:05
OF*Hash: Call [self reset] in -[dealloc] file: [706ddd8337] check-in: [096dd743b5] user: js, branch: trunk, size: 5113 [annotate] [blame] [check-ins using] [diff]
18:54
OFCryptoHash: Conform to OFCopying file: [3f98abf1a7] check-in: [b1cd76a8cd] user: js, branch: trunk, size: 5058 [annotate] [blame] [check-ins using] [diff]
12:14
-[OFCryptoHash digest]: uint8_t -> unsigned char

While in practice they are usually the same, the C standard says that
only char does not have any alignment requirements. As (u)int*_t is
defined to be an integer type of the specified size, it does not mean
(u)int8_t needs to be char. file: [2324ca56a2] check-in: [19f7dc67af] user: js, branch: trunk, size: 4781 [annotate] [blame] [check-ins using] [diff]

00:06
Rename OFHash to OFCryptoHash

OFHash is too generic, as this protocol is for cryptographic hashes. It
also solves the ambiguity of the +[hash] method (which is now
+[cryptoHash]), which conflicted with -[hash] on the class itself,
resulting in classes conforming to OFHash not being able to be used as a
key in an OFDictionary. file: [6b2637992f] check-in: [951f530aee] user: js, branch: trunk, size: 4775 [annotate] [blame] [check-ins using] [diff]

2016-02-21
15:37
Make use of C99-style for loops file: [6ab18f2a4c] check-in: [e0b9167693] user: js, branch: trunk, size: 4576 [annotate] [blame] [check-ins using] [diff]
2016-01-05
22:00
(u)int_fast*_t -> (u)int*_t

(U)INT_FAST*_MAX is broken on Android, which makes (u)int_fast*_t
dangerous to use while it does not provide any real speed benefit. file: [80ddf15097] check-in: [d3158d091f] user: js, branch: trunk, size: 4581 [annotate] [blame] [check-ins using] [diff]

2016-01-03
00:43
Update copyright

While at it, also update the mail address. file: [5dc4ddd7b0] check-in: [cec0f072f8] user: js, branch: 0.8, size: 4767 [annotate] [blame] [check-ins using] [diff]

00:41
Update copyright

While at it, also update the mail address. file: [56e8b6283e] check-in: [2a27cf3000] user: js, branch: trunk, size: 4596 [annotate] [blame] [check-ins using] [diff]

2015-11-29
11:43
Make properties a requirement and clean up code

This increases the required GCC version from 4.0 to 4.6 (exception:
Apple GCC, which already supports this with >= 4.0 starting with OS X
10.5). Since even GCC 4.6 is really old by now, there is no point in
still supporting something even older and making the code ugly because
of that. While some hardware and OS support was dropped from GCC 4.6
compared to GCC 4.0, there is nothing in there that would be an
interesting target with the exception of BeOS maybe - but a port to BeOS
can also be achieved using the Haiku support. The other dropped OSes are
mostly old versions of OSes while newer ones are still being supported
(and those newer versions of those OSes still support the same
hardware). file: [f2934a633d] check-in: [48980f2297] user: js, branch: trunk, size: 4592 [annotate] [blame] [check-ins using] [diff]

2015-11-02
19:27
OFSHA*Hash: Minor cleanup file: [d23742f855] check-in: [6a3c47863d] user: js, branch: trunk, size: 4600 [annotate] [blame] [check-ins using] [diff]
2015-02-01
00:47
Add -[OFHash reset]

This is useful to calculate many hashes without allocating new objects. file: [1adbe2ccf4] check-in: [7c27db9fe0] user: js, branch: trunk, size: 4763 [annotate] [blame] [check-ins using] [diff]

2015-01-31
11:46
OF{MD5,RIPEMD160,SHA*}Hash: Small optimization file: [4bdaecb076] check-in: [c56b388459] user: js, branch: trunk, size: 4575 [annotate] [blame] [check-ins using] [diff]
2015-01-03
20:57
Update copyright file: [47de21ef82] check-in: [cfd374b906] user: js, branch: trunk, size: 4542 [annotate] [blame] [check-ins using] [diff]
2014-09-03
14:30
Added: Rename OFSHA224OrSHA256Hash to OFSHA224Or256Hash file: [65b2db21e0] check-in: [42e4ed36ee] user: js, branch: trunk, size: 4536 [annotate] [blame] [check-ins using]