ObjFW  History of src/OFSHA224Or256Hash.h of e0459c419cca642f

History of the file that is called src/OFSHA224Or256Hash.h at checkin e0459c419cca642f

2021-04-07
21:14
Rename OFCryptoHash -> OFCryptographicHash file: [f40021c439] check-in: [2969086342] user: js, branch: trunk, size: 1188 [annotate] [blame] [check-ins using] [diff]
2021-01-02
22:04
Update copyright file: [25d2fa7cb5] check-in: [374e1a1bfa] user: js, branch: trunk, size: 1174 [annotate] [blame] [check-ins using] [diff]
2020-10-03
11:35
Use /** */ instead of /*! */ for documentation file: [0f791ad851] check-in: [163a4a5a2e] user: js, branch: trunk, size: 1263 [annotate] [blame] [check-ins using] [diff]
2020-09-26
21:58
Don't require __COUNTER__ for OF_RESERVE_IVARS

__COUNTER__ does not exist in GCC 4.2, and Apple GCC 4.2 is still the
newest compiler available for macOS 10.5. file: [0b7290b7e9] check-in: [ef614a225d] user: js, branch: trunk, size: 1263 [annotate] [blame] [check-ins using] [diff]

2020-04-19
14:52
Reduce usage of unions file: [deb793f9c1] check-in: [e0459c419c] user: js, branch: trunk, size: 1244 [annotate] [blame] [check-ins using] [diff]
2020-01-02
01:51
Update copyright file: [9b410449c3] check-in: [c7f0229795] user: js, branch: trunk, size: 1238 [annotate] [blame] [check-ins using] [diff]
2019-12-27
00:41
OFSecureData: Add allowsSwappableMemory property

With this property, it's possible to specify whether the memory should
be protected from swapping or not. This makes it easier for e.g. the
crypto hash classes: They can now just always use OFSecureData without
wasting unswappable memory if it's not needed. file: [b17aa63913] check-in: [e629dc83a9] user: js, branch: trunk, size: 1235 [annotate] [blame] [check-ins using] [diff]

2019-09-29
20:53
Reduce ivar scopes file: [e39de03a34] check-in: [e0a330b377] user: js, branch: trunk, size: 1205 [annotate] [blame] [check-ins using] [diff]
19:35
Either restrict subclassing or reserve ivar space

This allows ABI stability with the fragile ABI. file: [6b1a277f58] check-in: [496695d778] user: js, branch: trunk, size: 1176 [annotate] [blame] [check-ins using] [diff]

2019-01-03
19:13
Update copyright file: [0e59b3265f] check-in: [0509d7a844] user: js, branch: trunk, size: 1155 [annotate] [blame] [check-ins using] [diff]
2018-04-07
20:05
OF*Hash: Make use of the new OFSecureData file: [ff3ca7c0af] check-in: [a5006f1d31] user: js, branch: trunk, size: 1149 [annotate] [blame] [check-ins using] [diff]
2018-01-03
19:49
Update copyright notice file: [47eff0e7f8] check-in: [7e5c81e186] user: js, branch: trunk, size: 1048 [annotate] [blame] [check-ins using] [diff]
2017-05-21
21:28
Prefix private methods with of_ instead of OF_

This matches Apple's style. file: [d2b1bed551] check-in: [6b77a5dd8b] user: js, branch: trunk, size: 1025 [annotate] [blame] [check-ins using] [diff]

2017-04-02
16:02
Avoid the anonymous namespace for ObjC++ with GCC file: [d784642d5f] check-in: [35934a9594] user: js, branch: trunk, size: 1049 [annotate] [blame] [check-ins using] [diff]
2017-01-09
17:36
Update copyright

Forgot to add 2017, even though I already did quite some changes in
2017. file: [57c2a33df9] check-in: [44f45c2e35] user: js, branch: trunk, size: 1019 [annotate] [blame] [check-ins using] [diff]

2016-07-24
00:06
Rename OFHash to OFCryptoHash

OFHash is too generic, as this protocol is for cryptographic hashes. It
also solves the ambiguity of the +[hash] method (which is now
+[cryptoHash]), which conflicted with -[hash] on the class itself,
resulting in classes conforming to OFHash not being able to be used as a
key in an OFDictionary. file: [f6372245cc] check-in: [951f530aee] user: js, branch: trunk, size: 1013 [annotate] [blame] [check-ins using] [diff]

2016-01-03
00:41
Update copyright

While at it, also update the mail address. file: [29c76a9638] check-in: [2a27cf3000] user: js, branch: trunk, size: 1001 [annotate] [blame] [check-ins using] [diff]

2015-06-13
22:26
Add support for and use the new nullability file: [b9a0ba0397] check-in: [9e76144ef8] user: js, branch: trunk, size: 997 [annotate] [blame] [check-ins using] [diff]
2015-02-01
00:47
Add -[OFHash reset]

This is useful to calculate many hashes without allocating new objects. file: [257314d339] check-in: [7c27db9fe0] user: js, branch: trunk, size: 949 [annotate] [blame] [check-ins using] [diff]

2015-01-03
20:57
Update copyright file: [81c7fe9aca] check-in: [cfd374b906] user: js, branch: trunk, size: 925 [annotate] [blame] [check-ins using] [diff]
2014-09-03
14:30
Added: Rename OFSHA224OrSHA256Hash to OFSHA224Or256Hash file: [35650fa6ca] check-in: [42e4ed36ee] user: js, branch: trunk, size: 919 [annotate] [blame] [check-ins using]