ObjFW  History of src/OFMD5Hash.h of e0459c419cca642f

History of the file that is called src/OFMD5Hash.h at checkin e0459c419cca642f

2021-04-07
21:14
Rename OFCryptoHash -> OFCryptographicHash file: [308882c688] check-in: [2969086342] user: js, branch: trunk, size: 1109 [annotate] [blame] [check-ins using] [diff]
2021-01-02
22:04
Update copyright file: [2ab0f29af9] check-in: [374e1a1bfa] user: js, branch: trunk, size: 1095 [annotate] [blame] [check-ins using] [diff]
2020-10-03
11:35
Use /** */ instead of /*! */ for documentation file: [115122e9c6] check-in: [163a4a5a2e] user: js, branch: trunk, size: 1184 [annotate] [blame] [check-ins using] [diff]
2020-04-19
14:52
Reduce usage of unions file: [7314ebcbd4] check-in: [e0459c419c] user: js, branch: trunk, size: 1184 [annotate] [blame] [check-ins using] [diff]
2020-01-02
01:51
Update copyright file: [afbdcd7e31] check-in: [c7f0229795] user: js, branch: trunk, size: 1178 [annotate] [blame] [check-ins using] [diff]
2019-12-27
00:41
OFSecureData: Add allowsSwappableMemory property

With this property, it's possible to specify whether the memory should
be protected from swapping or not. This makes it easier for e.g. the
crypto hash classes: They can now just always use OFSecureData without
wasting unswappable memory if it's not needed. file: [dd0468f75a] check-in: [e629dc83a9] user: js, branch: trunk, size: 1175 [annotate] [blame] [check-ins using] [diff]

2019-09-29
19:35
Either restrict subclassing or reserve ivar space

This allows ABI stability with the fragile ABI. file: [7bc2b1da3f] check-in: [496695d778] user: js, branch: trunk, size: 1145 [annotate] [blame] [check-ins using] [diff]

2019-01-03
19:13
Update copyright file: [2507db3e19] check-in: [0509d7a844] user: js, branch: trunk, size: 1119 [annotate] [blame] [check-ins using] [diff]
2018-04-07
20:05
OF*Hash: Make use of the new OFSecureData file: [9ada856280] check-in: [a5006f1d31] user: js, branch: trunk, size: 1113 [annotate] [blame] [check-ins using] [diff]
2018-01-03
19:49
Update copyright notice file: [d676855739] check-in: [7e5c81e186] user: js, branch: trunk, size: 1021 [annotate] [blame] [check-ins using] [diff]
2017-05-21
21:28
Prefix private methods with of_ instead of OF_

This matches Apple's style. file: [61caed852a] check-in: [6b77a5dd8b] user: js, branch: trunk, size: 998 [annotate] [blame] [check-ins using] [diff]

2017-04-02
16:02
Avoid the anonymous namespace for ObjC++ with GCC file: [5fcb172421] check-in: [35934a9594] user: js, branch: trunk, size: 1022 [annotate] [blame] [check-ins using] [diff]
2017-01-09
17:36
Update copyright

Forgot to add 2017, even though I already did quite some changes in
2017. file: [1776f49d75] check-in: [44f45c2e35] user: js, branch: trunk, size: 1003 [annotate] [blame] [check-ins using] [diff]

2016-07-24
02:19
Minor documentation fix file: [3dc2448fdc] check-in: [79e447956c] user: js, branch: trunk, size: 997 [annotate] [blame] [check-ins using] [diff]
00:06
Rename OFHash to OFCryptoHash

OFHash is too generic, as this protocol is for cryptographic hashes. It
also solves the ambiguity of the +[hash] method (which is now
+[cryptoHash]), which conflicted with -[hash] on the class itself,
resulting in classes conforming to OFHash not being able to be used as a
key in an OFDictionary. file: [6e1b8b2c3a] check-in: [951f530aee] user: js, branch: trunk, size: 999 [annotate] [blame] [check-ins using] [diff]

2016-01-03
00:41
Update copyright

While at it, also update the mail address. file: [e1256fb017] check-in: [2a27cf3000] user: js, branch: trunk, size: 987 [annotate] [blame] [check-ins using] [diff]

2015-06-13
22:26
Add support for and use the new nullability file: [802d16ca17] check-in: [9e76144ef8] user: js, branch: trunk, size: 983 [annotate] [blame] [check-ins using] [diff]
2015-02-01
00:47
Add -[OFHash reset]

This is useful to calculate many hashes without allocating new objects. file: [f6743c94bf] check-in: [7c27db9fe0] user: js, branch: trunk, size: 935 [annotate] [blame] [check-ins using] [diff]

2015-01-03
20:57
Update copyright file: [03022e8a95] check-in: [cfd374b906] user: js, branch: trunk, size: 911 [annotate] [blame] [check-ins using] [diff]
2014-08-31
17:59
Rewrite OFMD5Hash

The old one was based on a public domain implementation, which is
optimized for old compilers and quite unreadable. The new one is written
from scratch and designed to be readable and to exploit optimizations of
modern compilers. file: [a3122408cc] check-in: [c4d2f177cb] user: js, branch: trunk, size: 905 [annotate] [blame] [check-ins using] [diff]

2014-02-18
18:50
Documentation: Show correct imports file: [8efb12ba3e] check-in: [246cfe0807] user: js, branch: trunk, size: 897 [annotate] [blame] [check-ins using] [diff]
2014-01-04
00:24
Update copyright. file: [400ee45e8f] check-in: [3b97fc3cd9] user: js, branch: trunk, size: 844 [annotate] [blame] [check-ins using] [diff]
2013-12-08
17:43
Clean up OFHash and the Hashing categories. file: [795e2e7102] check-in: [75f2aa5096] user: js, branch: trunk, size: 838 [annotate] [blame] [check-ins using] [diff]
2013-05-13
16:46
Get rid of a strange ObjC++ + Win32 warning. file: [fea508e8e7] check-in: [482454bc43] user: js, branch: trunk, size: 869 [annotate] [blame] [check-ins using] [diff]
2013-03-04
17:20
Replace BOOL with bool.

The only places where BOOL is left are those where they are required by
the ABI. file: [d2206bf3cb] check-in: [c5ef582958] user: js, branch: trunk, size: 849 [annotate] [blame] [check-ins using] [diff]

2013-02-18
23:05
Make OFHash a protocol. file: [833fa196ed] check-in: [9b2d255a3d] user: js, branch: trunk, size: 849 [annotate] [blame] [check-ins using] [diff]
2013-02-12
18:22
Prefix all ivars with an underscore. file: [efbff1e954] check-in: [e40729d406] user: js, branch: trunk, size: 819 [annotate] [blame] [check-ins using] [diff]
2013-01-09
22:24
Update copyright. file: [8c63eab3b8] check-in: [813c00ccf0] user: js, branch: trunk, size: 816 [annotate] [blame] [check-ins using] [diff]
2012-12-15
17:52
OFDataArray: Improve API. file: [569dd9f1c4] check-in: [c85ff8d35a] user: js, branch: trunk, size: 810 [annotate] [blame] [check-ins using] [diff]
2012-10-28
12:38
Switch to a headerdoc-compatible doc format. file: [b8a9b23fd3] check-in: [1ad9565253] user: js, branch: trunk, size: 811 [annotate] [blame] [check-ins using] [diff]
2012-07-03
20:16
OFHash: Take void* and unify convenience methods. file: [a6c35b82ad] check-in: [c1060114f6] user: js, branch: trunk, size: 811 [annotate] [blame] [check-ins using] [diff]
2012-01-05
00:56
Update copyright. file: [95439e160f] check-in: [ce70e17b38] user: js, branch: trunk, size: 909 [annotate] [blame] [check-ins using] [diff]
2011-05-08
17:19
More documentation improvements. file: [a9b4a2c9de] check-in: [242b1ccd71] user: js, branch: trunk, size: 903 [annotate] [blame] [check-ins using] [diff]
2011-04-22
20:19
More style improvements. file: [483543b630] check-in: [e76a7f52c1] user: js, branch: trunk, size: 864 [annotate] [blame] [check-ins using] [diff]
2011-03-11
16:44
Use a union instead of casting pointers in OF{MD5,SHA1}Hash. file: [bbea038319] check-in: [1d7ed6556d] user: js, branch: trunk, size: 861 [annotate] [blame] [check-ins using] [diff]
2011-01-01
20:19
Change license. file: [e0170a3623] check-in: [da6b3d26cb] user: js, branch: trunk, size: 825 [annotate] [blame] [check-ins using] [diff]
2010-10-24
13:30
Always write abbreviations uppercase in method names. file: [c66d914130] check-in: [1d19a5586b] user: js, branch: trunk, size: 569 [annotate] [blame] [check-ins using] [diff]
2010-06-12
20:47
Added: Move a few classes and categories so they have their own files. file: [06018586de] check-in: [67917b918a] user: js, branch: trunk, size: 569 [annotate] [blame] [check-ins using]