ObjFW  All files named "src/OFDeflateStream.h"

History for src/OFDeflateStream.h

2017-06-10
10:00
Deleted: Rename OFDeflateStream back to OFInflateStream

There is not much point in having a bi-directional stream for Deflate
compression / decompression. check-in: [f56a50ee50] user: js, branch: trunk, size: 0

2017-05-08
21:37
Add OF_DESIGNATED_INITIALIZER & OF_METHOD_FAMILY file: [9825418b97] check-in: [469a496cd2] user: js, branch: trunk, size: 2618 [annotate] [blame] [check-ins using] [diff]
2017-05-07
23:14
Add OF_UNAVAILABLE file: [e20e08f121] check-in: [16c05e87e1] user: js, branch: trunk, size: 2592 [annotate] [blame] [check-ins using] [diff]
20:10
Small code style change

Casts are now written like types in variable declarations. file: [f5d863787a] check-in: [4af49a13c3] user: js, branch: trunk, size: 2568 [annotate] [blame] [check-ins using] [diff]

2017-01-09
17:36
Update copyright

Forgot to add 2017, even though I already did quite some changes in
2017. file: [0d64fa32f0] check-in: [44f45c2e35] user: js, branch: trunk, size: 2566 [annotate] [blame] [check-ins using] [diff]

2016-05-29
14:15
OFDeflateStream: Separate ivars by (de)compression file: [b05d4c196d] check-in: [e9e89aa4c0] user: js, branch: trunk, size: 2560 [annotate] [blame] [check-ins using] [diff]
13:02
Added: Rename OFInflateStream back to OFDeflateStream

The reason for renaming to OFInflateStream was to have one stream for
decompression and one for compression in order to reduce memory usage if
only one of the two is needed, as the ivar layout will be smaller then.
However, it is more consistent with other stream classes to have one
stream that can handle both. The increased memory footprint of having
ivars for compression and decompression can be solved by having a
pointer to those instead. This will not incur any performance penalty,
as the pointer will be dereferenced instead of the ivars, meaning the
overhead is only getting the pointer from the ivars once. file: [da155ca87d] check-in: [134a1121c7] user: js, branch: trunk, size: 2902 [annotate] [blame] [check-ins using]

2015-05-16
20:29
Deleted: Rename OFDeflateStream -> OFInflateStream

It makes more sense to have one class for inflating and one for
deflating instead of having one that does both, as having one that does
both requires more memory per instance when only inflating or deflating
is used. check-in: [2e9336b1ef] user: js, branch: trunk, size: 0

2015-01-03
20:57
Update copyright file: [d491d41a8e] check-in: [cfd374b906] user: js, branch: trunk, size: 2933 [annotate] [blame] [check-ins using] [diff]
2014-05-31
02:16
Better code sharing between Deflate and Deflate64 file: [97a1014dfe] check-in: [a8c62e1c0d] user: js, branch: trunk, size: 2927 [annotate] [blame] [check-ins using] [diff]
2014-02-18
18:50
Documentation: Show correct imports file: [c9168b28f2] check-in: [246cfe0807] user: js, branch: trunk, size: 3114 [annotate] [blame] [check-ins using] [diff]
2014-01-04
00:24
Update copyright. file: [1efdac5dd5] check-in: [3b97fc3cd9] user: js, branch: trunk, size: 3043 [annotate] [blame] [check-ins using] [diff]
2013-11-06
20:29
Add OFDeflate64Stream. file: [ee0596ab39] check-in: [7aef43d648] user: js, branch: trunk, size: 3037 [annotate] [blame] [check-ins using] [diff]
2013-10-10
13:18
Added: Add OFDeflateStream.

No compression support yet, only decompression.

Decompression speed is acceptable for productive use, but there is still
a lot of room for optimization as this is a very straightforward
implementation without much optimization. file: [2f21e16d6f] check-in: [d83d3aa719] user: js, branch: trunk, size: 2827 [annotate] [blame] [check-ins using]