ObjFW  All files named "src/OFDataArray+CryptoHashing.m"

History for src/OFDataArray+CryptoHashing.m

2017-07-22
20:50
Deleted: Split OFDataArray into OFData and OFMutableData check-in: [c8f7b90082] user: js, branch: trunk, size: 0
2017-05-21
21:28
Prefix private methods with of_ instead of OF_

This matches Apple's style. file: [7a19dd94a4] check-in: [6b77a5dd8b] user: js, branch: trunk, size: 2315 [annotate] [blame] [check-ins using] [diff]

2017-05-07
20:10
Small code style change

Casts are now written like types in variable declarations. file: [07e9d87070] check-in: [4af49a13c3] user: js, branch: trunk, size: 2315 [annotate] [blame] [check-ins using] [diff]

2017-01-09
17:36
Update copyright

Forgot to add 2017, even though I already did quite some changes in
2017. file: [093e57a2e6] check-in: [44f45c2e35] user: js, branch: trunk, size: 2307 [annotate] [blame] [check-ins using] [diff]

2016-07-24
12:14
-[OFCryptoHash digest]: uint8_t -> unsigned char

While in practice they are usually the same, the C standard says that
only char does not have any alignment requirements. As (u)int*_t is
defined to be an integer type of the specified size, it does not mean
(u)int8_t needs to be char. file: [29df650203] check-in: [19f7dc67af] user: js, branch: trunk, size: 2301 [annotate] [blame] [check-ins using] [diff]

00:06
Added: Rename OFHash to OFCryptoHash

OFHash is too generic, as this protocol is for cryptographic hashes. It
also solves the ambiguity of the +[hash] method (which is now
+[cryptoHash]), which conflicted with -[hash] on the class itself,
resulting in classes conforming to OFHash not being able to be used as a
key in an OFDictionary. file: [c62437f34e] check-in: [951f530aee] user: js, branch: trunk, size: 2295 [annotate] [blame] [check-ins using]