ObjFW  History of src/OFCryptographicHash.h of e2284a0f02b9d535

History of the file that is called src/OFCryptographicHash.h at check-in e2284a0f02b9d535

2024-01-02
17:17
Update copyright file: [e658c9f212] check-in: [26ddd2e4e4] user: js, branch: trunk, size: 3627 [annotate] [blame] [check-ins using] [diff]
2023-01-06
09:04
Update copyright file: [bcec3c10c5] check-in: [8939cbdb52] user: js, branch: trunk, size: 3627 [annotate] [blame] [check-ins using] [diff]
2022-09-25
20:14
Document more exceptions file: [635d4f982a] check-in: [5a4e00df9a] user: js, branch: trunk, size: 3627 [annotate] [blame] [check-ins using] [diff]
2022-03-25
10:22
OFCryptographicHash: Add -[calculate]

Before, -[digest] would do the final calculation, however, this would
mean a property modifies state, which is bad. file: [21f208b184] check-in: [82801897d3] user: js, branch: trunk, size: 3386 [annotate] [blame] [check-ins using] [diff]

2022-02-12
07:46
Update copyright file: [68944dcb5c] check-in: [1a86b8175b] user: js, branch: trunk, size: 3290 [annotate] [blame] [check-ins using] [diff]
2021-04-07
21:14
Renamed src/OFCryptoHash.h → src/OFCryptographicHash.h. Rename OFCryptoHash -> OFCryptographicHash file: [3e39e62dc1] check-in: [2969086342] user: js, branch: trunk, size: 3290 [annotate] [blame] [check-ins using] [diff]
2021-03-07
15:07
*.h: Fold methods into one line where it fits file: [eb798114fa] check-in: [1948e7e972] user: js, branch: trunk, size: 3262 [annotate] [blame] [check-ins using] [diff]
2021-01-02
22:04
Update copyright file: [09ebd5cbd7] check-in: [374e1a1bfa] user: js, branch: trunk, size: 3266 [annotate] [blame] [check-ins using] [diff]
2020-10-03
11:35
Use /** */ instead of /*! */ for documentation file: [ec7cd6aa74] check-in: [163a4a5a2e] user: js, branch: trunk, size: 3355 [annotate] [blame] [check-ins using] [diff]
2020-01-02
01:51
Update copyright file: [aad503306a] check-in: [c7f0229795] user: js, branch: trunk, size: 3355 [annotate] [blame] [check-ins using] [diff]
2019-12-27
00:41
OFSecureData: Add allowsSwappableMemory property

With this property, it's possible to specify whether the memory should
be protected from swapping or not. This makes it easier for e.g. the
crypto hash classes: They can now just always use OFSecureData without
wasting unswappable memory if it's not needed. file: [ef88b31b2d] check-in: [e629dc83a9] user: js, branch: trunk, size: 3352 [annotate] [blame] [check-ins using] [diff]

2019-03-12
22:10
OFCryptoHash: Add property for digest / block size file: [b402221532] check-in: [320d638a21] user: js, branch: trunk, size: 2927 [annotate] [blame] [check-ins using] [diff]
2019-01-03
19:13
Update copyright file: [63898f6fd8] check-in: [0509d7a844] user: js, branch: trunk, size: 2683 [annotate] [blame] [check-ins using] [diff]
2018-01-03
19:49
Update copyright notice file: [bcc2f50f7b] check-in: [7e5c81e186] user: js, branch: trunk, size: 2677 [annotate] [blame] [check-ins using] [diff]
2017-11-18
18:50
Documentation: Use @brief for all properties file: [7d42c94152] check-in: [cc3ad3ddd3] user: js, branch: trunk, size: 2654 [annotate] [blame] [check-ins using] [diff]
2017-10-30
00:23
Add class properties where appropriate

This improves Swift compatibility. file: [2634ee9f93] check-in: [a2e849c681] user: js, branch: trunk, size: 2640 [annotate] [blame] [check-ins using] [diff]

2017-10-29
21:58
Convert methods to properties where appropriate

This improves Swift compatibility. file: [ab2417692f] check-in: [f3ccf14461] user: js, branch: trunk, size: 2485 [annotate] [blame] [check-ins using] [diff]

2017-05-13
16:29
Also use nonatomic for non-object properties file: [c3a8ed0de1] check-in: [f663d40cbd] user: js, branch: trunk, size: 2511 [annotate] [blame] [check-ins using] [diff]
2017-05-07
20:10
Small code style change

Casts are now written like types in variable declarations. file: [fb07c27325] check-in: [4af49a13c3] user: js, branch: trunk, size: 2500 [annotate] [blame] [check-ins using] [diff]

2017-01-09
17:36
Update copyright

Forgot to add 2017, even though I already did quite some changes in
2017. file: [14a9d18645] check-in: [44f45c2e35] user: js, branch: trunk, size: 2498 [annotate] [blame] [check-ins using] [diff]

2016-07-24
18:54
OFCryptoHash: Conform to OFCopying file: [7974c3e9f8] check-in: [b1cd76a8cd] user: js, branch: trunk, size: 2492 [annotate] [blame] [check-ins using] [diff]
12:14
-[OFCryptoHash digest]: uint8_t -> unsigned char

While in practice they are usually the same, the C standard says that
only char does not have any alignment requirements. As (u)int*_t is
defined to be an integer type of the specified size, it does not mean
(u)int8_t needs to be char. file: [91b722cbde] check-in: [19f7dc67af] user: js, branch: trunk, size: 2258 [annotate] [blame] [check-ins using] [diff]

00:06
Added: Rename OFHash to OFCryptoHash

OFHash is too generic, as this protocol is for cryptographic hashes. It
also solves the ambiguity of the +[hash] method (which is now
+[cryptoHash]), which conflicted with -[hash] on the class itself,
resulting in classes conforming to OFHash not being able to be used as a
key in an OFDictionary. file: [86d6230316] check-in: [951f530aee] user: js, branch: trunk, size: 2252 [annotate] [blame] [check-ins using]