ObjFW  Diff

Differences From Artifact [7efebe508a]:

To Artifact [bd7b819877]:

  • File src/OFDataArray.m — part of check-in [951f530aee] at 2016-07-24 00:06:30 on branch trunk — Rename OFHash to OFCryptoHash

    OFHash is too generic, as this protocol is for cryptographic hashes. It
    also solves the ambiguity of the +[hash] method (which is now
    +[cryptoHash]), which conflicted with -[hash] on the class itself,
    resulting in classes conforming to OFHash not being able to be used as a
    key in an OFDictionary. (user: js, size: 14882) [annotate] [blame] [check-ins using]


49
50
51
52
53
54
55

56
57
58
59
60
61
62
63
64

#import "base64.h"

/* References for static linking */
void
_references_to_categories_of_OFDataArray(void)
{

	_OFDataArray_MessagePackValue_reference = 1;
	_OFDataArray_Hashing_reference = 1;
}

@implementation OFDataArray
@synthesize itemSize = _itemSize;

+ (instancetype)dataArray
{







>

<







49
50
51
52
53
54
55
56
57

58
59
60
61
62
63
64

#import "base64.h"

/* References for static linking */
void
_references_to_categories_of_OFDataArray(void)
{
	_OFDataArray_CryptoHashing_reference = 1;
	_OFDataArray_MessagePackValue_reference = 1;

}

@implementation OFDataArray
@synthesize itemSize = _itemSize;

+ (instancetype)dataArray
{