ObjFW  Diff

Differences From Artifact [134bfc8e3c]:

To Artifact [77b4882e58]:

  • File src/OFDataArray.h — part of check-in [951f530aee] at 2016-07-24 00:06:30 on branch trunk — Rename OFHash to OFCryptoHash

    OFHash is too generic, as this protocol is for cryptographic hashes. It
    also solves the ambiguity of the +[hash] method (which is now
    +[cryptoHash]), which conflicted with -[hash] on the class itself,
    resulting in classes conforming to OFHash not being able to be used as a
    key in an OFDictionary. (user: js, size: 9101) [annotate] [blame] [check-ins using]


318
319
320
321
322
323
324
325
326
 */
- (void)writeToFile: (OFString*)path;
#endif
@end

OF_ASSUME_NONNULL_END

#import "OFDataArray+Hashing.h"
#import "OFDataArray+MessagePackValue.h"







|

318
319
320
321
322
323
324
325
326
 */
- (void)writeToFile: (OFString*)path;
#endif
@end

OF_ASSUME_NONNULL_END

#import "OFDataArray+CryptoHashing.h"
#import "OFDataArray+MessagePackValue.h"